Skip to main content

Search

Issues using controller with one computer system, but not with another (Error 10).

Comments

12 comments

  • Avatar
    Oscar Salgado

    for those using platform b+ as a standalone: Error 10 insufficient risorse for complete API.
    I have the same situation using a platform b+ as a standalone. I tried everything. except for the pci replacement, since i wanted to used on a notebook. my usb kept not recognizing it. so i bought the plarform m+ to see if it would work by the midi connection provided, and it did. never had to connect it to usb. please, inform about this to those who are using platform b+ as a standalone before buying. and please provide a better service in this q&a. i loved the products but if you don't do better in service it all goes to waste. kind regards.

    0
  • Avatar
    Yakuro

    G-BOY DROP DAT January 06, 2021 05:52

    X570 for any other having problems on Windows 10.
    just upgrade the firmware on another computer. I've already tried this I bought a PCI slot USB powered and then unplugged it after updating the firmware and plugged it into my computer motherboard x570 normally and it worked just fine.
    So your best bet is to upgrade the firmware on a different computer and then it should work on your computer that you wanted to work on.
    This happens because the firmware is old when you buy it. So it'll work on a Windows 7 but not 10 because the firmware is for Windows 7 that's on the controller itself. ..... -
    I would love to install a new firmware. But the newest is more than 2 years old. And after a year of the problem, the ICONAUDIO company is in no hurry to fix this problem. For a year Karl ...

    0
  • Avatar
    G-BOY DROP DAT

    X570 for any other having problems on Windows 10.
    just upgrade the firmware on another computer. I've already tried this I bought a PCI slot USB powered and then unplugged it after updating the firmware and plugged it into my computer motherboard x570 normally and it worked just fine.
    So your best bet is to upgrade the firmware on a different computer and then it should work on your computer that you wanted to work on.
    This happens because the firmware is old when you buy it. So it'll work on a Windows 7 but not 10 because the firmware is for Windows 10 that's on the controller itself.

    0
  • Avatar
    Oscar Salgado

    Error 10 insufficient risorse for complete API. also I have tried everything!

    0
  • Avatar
    Toby AM

    I just upgraded to a x570 board and now the Platform M+ doesn't work! Why god why me.

    0
  • Avatar
    Reinhard Claus

    Same issue with my TRX40 aorus board, getting a cheap external USB 3.0 card solved it!

    0
  • Avatar
    Jonatan Campolo

    My computer don't use chipset x570 but anyWay no work. Error 10 insufficient risorse for complete API. I TRY EVRYTHING HELP ME.

    0
  • Avatar
    dawnrune11

    I have the same issue with the x570 - Guess I'll order a pci usb card now...

    0
  • Avatar
    G-BOY DROP DAT

    X570 for any other having problems on Windows 10.
    just upgrade the firmware on another computer. I've already tried this I bought a PCI slot USB powered and then unplugged it after updating the firmware and plugged it into my computer motherboard x570 normally and it worked just fine.
    So your best bet is to upgrade the firmware on a different computer and then it should work on your computer that you wanted to work on.
    This happens because the firmware is old when you buy it. So it'll work on a Windows 7 but not 10 because the firmware is for Windows 7 that's on the controller itself.

    0
  • Avatar
    Andy Mees

    For reference:

    For me, upgrading the Firmware (on another machine) on both M+ and X+ units addresses the 'Error 10' USB device connection issue on X570 motherboards. I have one Platform M+ and one Platform X+ running latest firmware (at time of writing being V2.16 and V2.10 respectively). Both are connecting without issue on my X570 motherboard via native chipset.

    However, the latest firmware available for the original Platform X units (V2.01 at time of writing) unfortunately does not address the issue and continues to require the use of a third party PCIe USB solution to circumvent.

    0
  • Avatar
    Victor Johnson

    OMG, I was so excited to use this thing... Just upgraded to x570 as well. the fix also doesn't work for me. Just ordered the PCI USB card. hopefully that will fix it. Was thiiiiis " " close to getting an avid control surface. Maybe I should've...

    0
  • Avatar
    Benjamin Schmitt

    Reinhard - Which External Usb 3.0 Card did you buy? I do not want to get a PCI based card ...

    0

Article is closed for comments.